const regex = /e([bngr][odbp]?[poy]){2}/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('e([bngr][odbp]?[poy]){2}', 'gi')
const str = `ebony
enoby
ebondy
eboby
egogy
ebory
enobby
enopby
enony`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}