import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "e([bngr][odbp]?[poy]){2}";
final String string = "ebony\n"
+ "enoby\n"
+ "ebondy\n"
+ "eboby\n"
+ "egogy\n"
+ "ebory\n"
+ "enobby\n"
+ "enopby\n"
+ "enony";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}