package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b([0-1]+)\b`)
var str = `101`
var substitution = "0$1~010"
fmt.Println(re.ReplaceAllString(str, substitution))
}