$re = '/\b([0-1]+)\b/';
$str = '101';
$subst = "0$1~010";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;