import Foundation
let pattern = #"\b([0-1]+)\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"101"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"0$1~010"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)