use strict;
my $str = '101';
my $regex = qr/\b([0-1]+)\b/p;
my $subst = '0$1~010';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";