#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!(?:[^A\n]*A){2})(?!(?:[^B\n]*B){3})(?!(?:[^C\n]*C){2})(?!(?:[^D\n]*D){2})(?:[ABCD](?:\s|$)){3}"
Local $sString = "# These are valid:" & @CRLF & _
"A B C" & @CRLF & _
"A B B" & @CRLF & _
"B C B" & @CRLF & _
"D A B" & @CRLF & _
"" & @CRLF & _
"# These are invalid:" & @CRLF & _
"A A B" & @CRLF & _
"B B B"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")