$re = '/^(?!(?:[^A\n]*A){2})(?!(?:[^B\n]*B){3})(?!(?:[^C\n]*C){2})(?!(?:[^D\n]*D){2})(?:[ABCD](?:\s|$)){3}/m';
$str = '# These are valid:
A B C
A B B
B C B
D A B
# These are invalid:
A A B
B B B';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);