const regex = /^(?!(?:[^A\n]*A){2})(?!(?:[^B\n]*B){3})(?!(?:[^C\n]*C){2})(?!(?:[^D\n]*D){2})(?:[ABCD](?:\s|$)){3}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!(?:[^A\\n]*A){2})(?!(?:[^B\\n]*B){3})(?!(?:[^C\\n]*C){2})(?!(?:[^D\\n]*D){2})(?:[ABCD](?:\\s|$)){3}', 'gm')
const str = `# These are valid:
A B C
A B B
B C B
D A B
# These are invalid:
A A B
B B B`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}