# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?!(?:[^A\n]*A){2})(?!(?:[^B\n]*B){3})(?!(?:[^C\n]*C){2})(?!(?:[^D\n]*D){2})(?:[ABCD](?:\s|$)){3}"
test_str = ("# These are valid:\n"
"A B C\n"
"A B B\n"
"B C B\n"
"D A B\n\n"
"# These are invalid:\n"
"A A B\n"
"B B B")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.