use strict;
my $str = '# These are valid:
A B C
A B B
B C B
D A B
# These are invalid:
A A B
B B B';
my $regex = qr/^(?!(?:[^A\n]*A){2})(?!(?:[^B\n]*B){3})(?!(?:[^C\n]*C){2})(?!(?:[^D\n]*D){2})(?:[ABCD](?:\s|$)){3}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}