import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<function>def\\s+(?P<function_name>\\w+)\\s*\\((?P<parameters>(?:.|\\n)*?)\\):\\s*(?:\\n[ \\t]+.*?)*\\n)";
final String string = "def sample_function1(arg1, arg2):\n"
+ " result = arg1 + arg2\n"
+ " if result > 10:\n"
+ " print(\"Greater than 10\")\n"
+ " else:\n"
+ " print(\"Not greater than 10\")\n"
+ " return result\n\n"
+ "def sample_function2(arg1, arg2):\n"
+ " result = arg1 - arg2\n"
+ " if result < 0:\n"
+ " print(\"Negative result\")\n"
+ " else:\n"
+ " print(\"Non-negative result\")\n"
+ " return result\n\n"
+ "def sample_function3(arg1, \n"
+ " arg2):\n"
+ " result = arg1 + arg2\n"
+ " if result > 10:\n"
+ " print(\"Greater than 10\")\n"
+ " else:\n"
+ " print(\"Not greater than 10\")\n"
+ " return result\n\n"
+ "class SampleClass1:\n"
+ " def __init__(self, arg1, arg2):\n"
+ " self.arg1 = arg1\n"
+ " self.arg2 = arg2\n\n"
+ " def sample_method1(self):\n"
+ " result = self.arg1 + self.arg2\n"
+ " return result\n\n"
+ "class SampleClass2:\n"
+ " def __init__(self, \n"
+ " arg1, \n"
+ " arg2):\n"
+ " self.arg1 = arg1\n"
+ " self.arg2 = arg2\n\n"
+ " def sample_method1(self):\n"
+ " result = self.arg1 + self.arg2\n"
+ " return result\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}