import re
regex = re.compile(r"(?P<function>def\s+(?P<function_name>\w+)\s*\((?P<parameters>(?:.|\n)*?)\):\s*(?:\n[ \t]+.*?)*\n)")
test_str = ("def sample_function1(arg1, arg2):\n"
" result = arg1 + arg2\n"
" if result > 10:\n"
" print(\"Greater than 10\")\n"
" else:\n"
" print(\"Not greater than 10\")\n"
" return result\n\n"
"def sample_function2(arg1, arg2):\n"
" result = arg1 - arg2\n"
" if result < 0:\n"
" print(\"Negative result\")\n"
" else:\n"
" print(\"Non-negative result\")\n"
" return result\n\n"
"def sample_function3(arg1, \n"
" arg2):\n"
" result = arg1 + arg2\n"
" if result > 10:\n"
" print(\"Greater than 10\")\n"
" else:\n"
" print(\"Not greater than 10\")\n"
" return result\n\n"
"class SampleClass1:\n"
" def __init__(self, arg1, arg2):\n"
" self.arg1 = arg1\n"
" self.arg2 = arg2\n\n"
" def sample_method1(self):\n"
" result = self.arg1 + self.arg2\n"
" return result\n\n"
"class SampleClass2:\n"
" def __init__(self, \n"
" arg1, \n"
" arg2):\n"
" self.arg1 = arg1\n"
" self.arg2 = arg2\n\n"
" def sample_method1(self):\n"
" result = self.arg1 + self.arg2\n"
" return result\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")