import Foundation
let pattern = #"(?P<function>def\s+(?P<function_name>\w+)\s*\((?P<parameters>(?:.|\n)*?)\):\s*(?:\n[ \t]+.*?)*\n)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
def sample_function1(arg1, arg2):
result = arg1 + arg2
if result > 10:
print("Greater than 10")
else:
print("Not greater than 10")
return result
def sample_function2(arg1, arg2):
result = arg1 - arg2
if result < 0:
print("Negative result")
else:
print("Non-negative result")
return result
def sample_function3(arg1,
arg2):
result = arg1 + arg2
if result > 10:
print("Greater than 10")
else:
print("Not greater than 10")
return result
class SampleClass1:
def __init__(self, arg1, arg2):
self.arg1 = arg1
self.arg2 = arg2
def sample_method1(self):
result = self.arg1 + self.arg2
return result
class SampleClass2:
def __init__(self,
arg1,
arg2):
self.arg1 = arg1
self.arg2 = arg2
def sample_method1(self):
result = self.arg1 + self.arg2
return result
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)