re = /(?P<function>def\s+(?P<function_name>\w+)\s*\((?P<parameters>(?:.|\n)*?)\):\s*(?:\n[ \t]+.*?)*\n)/
str = 'def sample_function1(arg1, arg2):
result = arg1 + arg2
if result > 10:
print("Greater than 10")
else:
print("Not greater than 10")
return result
def sample_function2(arg1, arg2):
result = arg1 - arg2
if result < 0:
print("Negative result")
else:
print("Non-negative result")
return result
def sample_function3(arg1,
arg2):
result = arg1 + arg2
if result > 10:
print("Greater than 10")
else:
print("Not greater than 10")
return result
class SampleClass1:
def __init__(self, arg1, arg2):
self.arg1 = arg1
self.arg2 = arg2
def sample_method1(self):
result = self.arg1 + self.arg2
return result
class SampleClass2:
def __init__(self,
arg1,
arg2):
self.arg1 = arg1
self.arg2 = arg2
def sample_method1(self):
result = self.arg1 + self.arg2
return result
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end