using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/?(cart\/done|cart\/auto\/done).*";
string input = @"cart/auto/done/?tx=99445068UN007545N&st=Completed&amt=297.00&cc=USD&cm=&item_number=
/cart/done/?tx=5CW532565J668892C&st=Completed&amt=249.01&cc=USD&cm=&item_number=";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}