const regex = new RegExp('\\/?(cart\\/done|cart\\/auto\\/done).*', 'g')
const str = `cart/auto/done/?tx=99445068UN007545N&st=Completed&amt=297.00&cc=USD&cm=&item_number=
/cart/done/?tx=5CW532565J668892C&st=Completed&amt=249.01&cc=USD&cm=&item_number=`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}