package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\/?(cart\/done|cart\/auto\/done).*`)
var str = `cart/auto/done/?tx=99445068UN007545N&st=Completed&amt=297.00&cc=USD&cm=&item_number=
/cart/done/?tx=5CW532565J668892C&st=Completed&amt=249.01&cc=USD&cm=&item_number=`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}