use strict;
my $str = 'cart/auto/done/?tx=99445068UN007545N&st=Completed&amt=297.00&cc=USD&cm=&item_number=
/cart/done/?tx=5CW532565J668892C&st=Completed&amt=249.01&cc=USD&cm=&item_number=';
my $regex = qr/\/?(cart\/done|cart\/auto\/done).*/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}