// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\/?(cart\/done|cart\/auto\/done).*").unwrap();
let string = "cart/auto/done/?tx=99445068UN007545N&st=Completed&amt=297.00&cc=USD&cm=&item_number=
/cart/done/?tx=5CW532565J668892C&st=Completed&amt=249.01&cc=USD&cm=&item_number=";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}