# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/Debug.*?endmsg(*SKIP)(*F)|restart-required//;t' <<< "Debug: testing message with no restart-required.endmsg.Warn:garbagestuff.Debug: another message.endmsg.Warn:moregarbage.Debug: this testing message has restart-required.endmsg.Error:server 404 not found.Critical restart-required. Debug: blah blah restart-required.endmsg."