import re
regex = re.compile(r"Debug.*?endmsg(*SKIP)(*F)|restart-required")
test_str = "Debug: testing message with no restart-required.endmsg.Warn:garbagestuff.Debug: another message.endmsg.Warn:moregarbage.Debug: this testing message has restart-required.endmsg.Error:server 404 not found.Critical restart-required. Debug: blah blah restart-required.endmsg."
subst = ""
result = regex.sub(subst, test_str, count=1)
if result:
print(result)