using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Debug.*?endmsg(*SKIP)(*F)|restart-required";
string substitution = @"";
string input = @"Debug: testing message with no restart-required.endmsg.Warn:garbagestuff.Debug: another message.endmsg.Warn:moregarbage.Debug: this testing message has restart-required.endmsg.Error:server 404 not found.Critical restart-required. Debug: blah blah restart-required.endmsg.";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}