using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!index)[a-zA-Z]+\.js";
string input = @"mid [sentence] match
foo[bar]
bar[foo]bar
defr.js
drefrf.frgt
trg/Frefze/FerfzeFE/Frfrfr/index.js";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}