$re = '/(?!index)[a-zA-Z]+\.js/';
$str = 'mid [sentence] match
foo[bar]
bar[foo]bar
defr.js
drefrf.frgt
trg/Frefze/FerfzeFE/Frfrfr/index.js';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);