import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?!index)[a-zA-Z]+\\.js";
final String string = "mid [sentence] match\n"
+ "foo[bar]\n"
+ "bar[foo]bar\n"
+ "defr.js\n"
+ "drefrf.frgt\n"
+ "trg/Frefze/FerfzeFE/Frfrfr/index.js";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}