re = /(?!index)[a-zA-Z]+\.js/
str = 'mid [sentence] match
foo[bar]
bar[foo]bar
defr.js
drefrf.frgt
trg/Frefze/FerfzeFE/Frfrfr/index.js'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end