#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^([^\|]{1,20})\|([^\|]{3,50})\|(([\d]{4}){4})\|((0[1-9]|1[0-2])(0[1-9]|[1-9][0-9]))$"
Local $sString = "ma cb|Moreau Marc|1234567890123456|0125"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")