import Foundation
let pattern = #"^([^\|]{1,20})\|([^\|]{3,50})\|(([\d]{4}){4})\|((0[1-9]|1[0-2])(0[1-9]|[1-9][0-9]))$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"ma cb|Moreau Marc|1234567890123456|0125"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}