import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^\\|]{1,20})\\|([^\\|]{3,50})\\|(([\\d]{4}){4})\\|((0[1-9]|1[0-2])(0[1-9]|[1-9][0-9]))$";
final String string = "ma cb|Moreau Marc|1234567890123456|0125";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}