// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^([^\|]{1,20})\|([^\|]{3,50})\|(([\d]{4}){4})\|((0[1-9]|1[0-2])(0[1-9]|[1-9][0-9]))$").unwrap();
let string = "ma cb|Moreau Marc|1234567890123456|0125";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}