package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^([^\|]{1,20})\|([^\|]{3,50})\|(([\d]{4}){4})\|((0[1-9]|1[0-2])(0[1-9]|[1-9][0-9]))$`)
var str = `ma cb|Moreau Marc|1234567890123456|0125`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}