#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)\bSTDMETHOD\b(.*?)\bPURE\b"
Local $sString = "STDMETHOD(MyFunc)(" & @CRLF & _
"D2D1_SIZE_U size," & @CRLF & _
"_In_opt_ CONST void *srcData," & @CRLF & _
") PURE;" & @CRLF & _
"" & @CRLF & _
"STDMETHOD(MyFunc2)(" & @CRLF & _
"_In_opt_ CONST void *srcData2," & @CRLF & _
"UINT32 pitch2, " & @CRLF & _
") PURE;"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")