# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\bSTDMETHOD\b(.*?)\bPURE\b"
test_str = ("STDMETHOD(MyFunc)(\n"
"D2D1_SIZE_U size,\n"
"_In_opt_ CONST void *srcData,\n"
") PURE;\n\n"
"STDMETHOD(MyFunc2)(\n"
"_In_opt_ CONST void *srcData2,\n"
"UINT32 pitch2, \n"
") PURE;")
matches = re.finditer(regex, test_str, re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.