import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bSTDMETHOD\\b(.*?)\\bPURE\\b";
final String string = "STDMETHOD(MyFunc)(\n"
+ "D2D1_SIZE_U size,\n"
+ "_In_opt_ CONST void *srcData,\n"
+ ") PURE;\n\n"
+ "STDMETHOD(MyFunc2)(\n"
+ "_In_opt_ CONST void *srcData2,\n"
+ "UINT32 pitch2, \n"
+ ") PURE;";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}