re = /\bSTDMETHOD\b(.*?)\bPURE\b/
str = 'STDMETHOD(MyFunc)(
D2D1_SIZE_U size,
_In_opt_ CONST void *srcData,
) PURE;
STDMETHOD(MyFunc2)(
_In_opt_ CONST void *srcData2,
UINT32 pitch2,
) PURE;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end