package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(http[s]?:[\/]{2}|[\/]{2})??([a-z0-9\-\.]+)??(youtube.com|youtu.be)\/(watch|v|embed)[/]?(\?v=|v\/)?([a-z0-9]{11,})`)
var str = `https://www.youtube.com/watch?v=NJLfCBBcZAo
http://www.youtube.com/watch?v=NJLfCBBcZAo`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}