const regex = /(http[s]?:[\/]{2}|[\/]{2})??([a-z0-9\-\.]+)??(youtube.com|youtu.be)\/(watch|v|embed)[/]?(\?v=|v\/)?([a-z0-9]{11,})/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(http[s]?:[\\\/]{2}|[\\\/]{2})??([a-z0-9\\-\\.]+)??(youtube.com|youtu.be)\\\/(watch|v|embed)[\/]?(\\?v=|v\\\/)?([a-z0-9]{11,})', 'i')
const str = `https://www.youtube.com/watch?v=NJLfCBBcZAo
http://www.youtube.com/watch?v=NJLfCBBcZAo`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}