re = /(http[s]?:[\/]{2}|[\/]{2})??([a-z0-9\-\.]+)??(youtube.com|youtu.be)\/(watch|v|embed)[\/]?(\?v=|v\/)?([a-z0-9]{11,})/i
str = 'https://www.youtube.com/watch?v=NJLfCBBcZAo
http://www.youtube.com/watch?v=NJLfCBBcZAo'
# Print the match result
str.match(re) do |match|
puts match.to_s
end