$re = '/(http[s]?:[\/]{2}|[\/]{2})??([a-z0-9\-\.]+)??(youtube.com|youtu.be)\/(watch|v|embed)[/]?(\?v=|v\/)?([a-z0-9]{11,})/i';
$str = 'https://www.youtube.com/watch?v=NJLfCBBcZAo
http://www.youtube.com/watch?v=NJLfCBBcZAo';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);