use strict;
my $str = 'https://www.youtube.com/watch?v=NJLfCBBcZAo
http://www.youtube.com/watch?v=NJLfCBBcZAo';
my $regex = qr/(http[s]?:[\/]{2}|[\/]{2})??([a-z0-9\-\.]+)??(youtube.com|youtu.be)\/(watch|v|embed)[/]?(\?v=|v\/)?([a-z0-9]{11,})/ip;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}