using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\w\w\w\w$";
string input = @"virūpa...
...caká¹£us
dharmacaká¹£us
nayacaká¹£us-
-sÅ«ryacaká¹ £us
Q di
? saṃgrah
Äsaṃgrah
upasaṃgrah
W pratisaṃgrah
abhisaṃgrah
M anusaṃgrah";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}