package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\w\w\w\w$`)
var str = `virūpa...
...caká¹£us
dharmacaká¹£us
nayacaká¹£us-
-sūryacakṣus
Q di
? saṃgrah
Äsaṃgrah
upasaṃgrah
W pratisaṃgrah
abhisaṃgrah
M anusaṃgrah`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}