re = /\w\w\w\w$/
str = 'virūpa...
...caká¹£us
dharmacaká¹£us
nayacaká¹£us-
-sūryacakṣus
Q di
? saṃgrah
Äsaṃgrah
upasaṃgrah
W pratisaṃgrah
abhisaṃgrah
M anusaṃgrah'
# Print the match result
str.match(re) do |match|
puts match.to_s
end