// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\w\w\w\w$").unwrap();
let string = "virūpa...
...caká¹£us
dharmacaká¹£us
nayacaká¹£us-
-sūryacakṣus
Q di
? saṃgrah
Äsaṃgrah
upasaṃgrah
W pratisaṃgrah
abhisaṃgrah
M anusaṃgrah";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}