using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(http:\/\/)?(www\.)?\w*\.(com|net|org)$";
string input = @"stackoverflow
stackoverflow.com
www.stackoverflow.com
http://www.stackoverflow.com
someone@stackoverflow.com
foo.bar";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}