package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(http:\/\/)?(www\.)?\w*\.(com|net|org)$`)
var str = `stackoverflow
stackoverflow.com
www.stackoverflow.com
http://www.stackoverflow.com
someone@stackoverflow.com
foo.bar`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}