re = /^(http:\/\/)?(www\.)?\w*\.(com|net|org)$/m
str = 'stackoverflow
stackoverflow.com
www.stackoverflow.com
http://www.stackoverflow.com
someone@stackoverflow.com
foo.bar'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end