$re = '/^(http:\/\/)?(www\.)?\w*\.(com|net|org)$/m';
$str = 'stackoverflow
stackoverflow.com
www.stackoverflow.com
http://www.stackoverflow.com
someone@stackoverflow.com
foo.bar';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);