#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(Mrs. |Mrs |Mrs. |Mrs|Mr. |Mr |Mr.|Mr|Ms. |Ms |Ms.|Ms)\w*"
Local $sString = "Hello Mr. Brown how are you today? Good, my name is Ms. Smith ok"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")